Error while deploying docker pipeline in offline environment


I’m trying to deploy a simple pipeline with docker on a server disconnected from internet.
I have a working docker registry accessible at registry.loc.
In a gitea repo I have a python code and the following .drone.yml file.

kind: pipeline
type: docker
name: default

  - name: db
    image: registry.loc:5000/db:latest
      - python -u -m db
      dockerfile: db.Dockerfile
      insecure: true
      repo: registry.loc:5000

When running the pipeline, I have the following error in the web console logs at the “clone” step:

Error response from daemon: Get "": dial tcp: lookup Temporary failure in name resolution

I have tried everything I could from the documentation…

Is there a way to tell the drone-runner to not use the default docker registry?


I finally managed to solve the issue myself…

During the clone step, drone pull the image drone/git:latest. Importing the image on the server solved this issue.

I think it could be useful to add more context in the logs in debug mode…
It would have saved me a lot of time…

For reference: drone-runner-docker/clone.go at 7e9969423c0883c0300c974bbb7583e3d9ece875 · drone-runners/drone-runner-docker · GitHub