[Windows] [ssh-runner] cloning skips the rest of the pipeline if there is a separate step called "clone"

When I don’t add

  disable: true

or set disable to false explicitly, every step in the pipeline is marked as “skipped”
and the whole pipeline is marked as successful.

After having written this, I noticed the actual cause for this behavior. It’s not just because I enabled it, but because I had a separate step that was also called “clone”.

Usually when steps have duplicate names the linter complains “pipelinename: Linter: duplicate step name”.

Apparently enabling cloning and naming a step “clone” somehow cirumvents the linter and triggers this odd behavior.

correct, the linter should error if cloning is enabled (or not disabled) and a step named clone exists. relevant code at https://github.com/drone-runners/drone-runner-ssh/blob/master/engine/resource/parser.go#L39