We couldn’t deliver this payload: timed out

Hey there,

We have noticed a problem in our organization with one of our repositories. For the rest of them (we have it few) CI get invoked correctly and builds successfully.
Suddenly for 2 days, any pushes don’t invoke drone CI. To be honest, it was working correctly for a long time and we didn’t change the .drone.yml content in any way.

  • In the GitHub/webhooks we could spot time out error: We couldn’t deliver this payload: timed out
  • We have chosen four webhooks that should invoke CI (branch or tag creation/branch or tag deletion/pushes/pull request)
  • Three of them gets time out (branch or tag creation/branch or tag deletion/pushes), one of them is delivered successfully (pull request), but we have enabled Ignore Pull Request in the drone configuration so it isn’t invoking CI.
  • I have checked the filename in the repository configuration on the drone, and the one on the GitHub repository and they match.
  • The content of the drone file and its filename didn’t change for over a month.
  • I didn’t see any useful information in our nginx logs.
  • I could see only an error in drone logs itself:
    {“commit”:“XXX”,“error”:“Not Found”,“event”:“push”,“level”:“warning”,“msg”:“trigger: cannot find yaml”,“ref”:"refs/XXX,“repo”:“XXX”,“time”:“2021-11-25T11:59:32Z”}
  • The yaml itself on repository and commit is reachable by querying GitHub API by curl with proper token/address.

What gives me a headache is that we have many repositories and the problem occurs in only one of them - suddenly where nobody has changed anything related to .drone.yml file. The endpoint for other webhooks is the same so it is not a problem related to unreachable URL because another webhooks on another repository invokes CI correctly.

We are using drone v2.4.0.

Is there a change for any support/tips?

Thanks in advice

Hey @Michal_Goldys

Have you tried the following : Error cannot find yaml

Yeah, I’ve checked out those steps but they didn’t help me discover the cause of that state.
Everything looks like it should.
Users (even I have tried) belongs to the proper organisation which is authorized to the drone itself.
I even tried to trigger CI by myself, so I created a new branch with .drone.yml and I have pushed some commits but the result is the same - time out, and in the logs, there’s information like I have pasted before.

The screen below in GitHub, settings => webhooks - have you verified the events are ticked for that repository?

Failing that to look into this further we would need the following:

  1. Provide your server configuration
  2. Provide your full server logs with debug logging enabled. Do not omit log entries.
  3. Provide your yaml configuration file
  4. Provide a copy of the webhook payload and headers from GitHub
  5. Provide a copy of the webhook response in GitHub