We couldn’t deliver this payload: Service Timeout

Hi Team i am facing issue with github webhook payload from last 4 days but i am unable to fix this issue. I have configured this on AWS Ubuntu 16.04 Instance nad for Github i have used my Git accout

Below is the configuration file i used to connect:

after pushing to github i am getting We couldn’t deliver this payload: Service Timeout.

Please help me to fix this issue.


A service timeout would indicate GitHub cannot reach your servers. Have you checked your network and server firewalls to ensure they can accept traffic from external sources? Also have you confirmed the webhook address being used is correct?

1 Like

Yes, the webhook address is correct and the firewalls also accepting the traffic from external sources.

Thanks a Ton,

Works fine…

what was the solution?? I have the same problem but unable to fix it from a couple of days.

Please let me know how you fixed it , i am stuck with this for last 7 days .Thanks!

@prajnadnayak @bijayrana
Hi, did you solve this problem?
I also encountered the same problem.

In my case, configuration file name on drone repository settings is .drone.yml but I set .drone.yaml on my repository root.
Therefore I fixed file name from .drone.yaml to .drone.yml , I’ve solved this issue.
I’m glad if you can use it.

bye :smiley:


This was very helpful… such a simple oversight caused 2 hours of debugging.

1 Like