Unable to run drone-runner-docker on ARM64/v8

Trying to setup automated building for packages on ARM how ever I am not able to install / download the drone-runner-docker for ARM64/v8

  docker run --detach \
    --volume=/var/run/docker.sock:/var/run/docker.sock \
    --env=DRONE_RPC_PROTO=https \
    --env=DRONE_RPC_HOST=drone.xxxx.xyz \
    --env=DRONE_RPC_SECRET=xxxx \
    --env=DRONE_RUNNER_NAME=runner-arm \
    --publish=3000:3000 \
    --restart=always \
    --name=runner \

But when I run the command on my server:
WARNING: The requested image’s platform (linux/amd64) does not match the detected host platform (linux/arm64/v8) and no specific platform was requested

When I run: uname -a

ubuntu@instance-20211029-1448:~$ uname -a
Linux instance-20211029-1448 5.11.0-1019-oracle #20~20.04.1-Ubuntu SMP Tue Sep 21 14:20:46 UTC 2021 aarch64 aarch64 aarch64 GNU/Linux

xxx have been replaced…


–platform=arm64 did the trick

Hi @jaapmarcus , did you manage to make it working?
I have an issue. Please check the following post:


@mg64ve he mentions he was able to get it working by including the --platform=arm64 flag in the docker run command.


I’m surprised that image tagged as arm and arm64 are in truth with AMD64 architecture. Something is missed while building these image ?

Thank you :slight_smile: