Unable to pull image from Microsoft (MCR)

I have a Dockerfile which bases on a Docker Image from MCR.

FROM mcr.microsoft.com/powershell/test-deps:ubuntu-18.04 AS builder

I tried a lot of variations, including other images from the registry, and it fails on my productive drone setup, on a test setup, such as drone exec. When I build it with docker build on the same machine, it works perfectly

[builder:95] Step 1/28 : FROM mcr.microsoft.com/powershell/test-deps:ubuntu-18.04 AS builder
[builder:96] Get https://mcr.microsoft.com/v2/: net/http: TLS handshake timeout
[builder:97] time="2021-09-21T11:16:28Z" level=fatal msg="exit status 1"

My docker registry is not affected, only MCR. Would be really grateful for a pointer in the right direction (or it is indeed a Bug on MCR or Drone).

Versions used:

  • Drone-CLI: Different Drone-CLIs up to 1.4.0
  • Drone Server and Runner (Docker): Multiple Versions up to the latest (last pulled on 19.09.2021)

The problem was the MTU. Setting it in .drone.yml to a lower value solved the issue for me.