Unable to mount volume for this plugin `drone-mvn-auth`

This is my demo repository.
I am trying to generate a customized maven settings.xml using this drone-mvn-auth plugin. As each tasks run in different containers, I tried to write to file into a volume which can be mounted to another task to utilize it.
But I get this default: linter: untrusted repositories cannot mount host volumes error when the pipeline job runs.
I tried few approaches mentioned in this forums, one is make the remo trusted from drone cli. Though the command runs successfully, the info of the repo didnt say the repo is trusted. Also I couldnt see the Trusted field in the UI.
I tried to add an admin user with drone cli, but that too fails with 403. I am the only user in this demo drone authenticated using public github.

How to make the “drone-mvn-auth” write the file into a volume mounted?

It sounds like you need to setup your account as the primary admin account so that you sufficient privileges to access admin functions. See https://docs.drone.io/server/user/admin/

I upgraded my drone cli version, now I have this error

You cannot perform this operation unless you are an admin. Please see the Create the Primary Admin section at this link to ensure your username is setup as an admin.