Unable to deploy drone server on openshift

Hello everyone,

I’m trying to deploy drone into my openshift cluster. To do this, I decide to use the official helm chart. After Installing the chart I have my drone-server pod which run and crash after couple of seconds with a weird error message which are not helpful for me to troubleshoot.

drone-drone-server-69bcc9fc88-mh2kr server {"level":"info","msg":"main: kubernetes scheduler enabled","time":"2019-12-03T13:57:46Z"}
drone-drone-server-69bcc9fc88-mh2kr server {"build.limit":5000,"expires":"0001-01-01T00:00:00Z","kind":"trial","level":"debug","msg":"main: license loaded","repo.limit":0,"time":"2019-12-03T13:57:47Z","user.limit":0}
drone-drone-server-69bcc9fc88-mh2kr server {"admin":true,"level":"debug","login":"admin","machine":false,"msg":"bootstrap: create account","time":"2019-12-03T13:57:47Z","token":""}
drone-drone-server-69bcc9fc88-mh2kr server {"admin":true,"level":"debug","login":"admin","machine":false,"msg":"bootstrap: updating account","time":"2019-12-03T13:57:47Z","token":""}
drone-drone-server-69bcc9fc88-mh2kr server {"admin":true,"level":"debug","login":"admin","machine":false,"msg":"bootstrap: account already up-to-date","time":"2019-12-03T13:57:47Z","token":""}
drone-drone-server-69bcc9fc88-mh2kr server {"acme":false,"host":"drone-drone","level":"info","msg":"starting the http server","port":":80","proto":"http","time":"2019-12-03T13:57:47Z","url":"http://drone-drone"}
drone-drone-server-69bcc9fc88-mh2kr server {"interval":"30m0s","level":"info","msg":"starting the cron scheduler","time":"2019-12-03T13:57:47Z"}
drone-drone-server-69bcc9fc88-mh2kr server interrupt received, terminating process
drone-drone-server-69bcc9fc88-mh2kr server {"error":"context canceled","level":"fatal","msg":"program terminated","time":"2019-12-03T13:58:05Z"}

I tried to enable debug logging and all log traces but same result I did not see any additional messages which can help me to understand.

Can you help me on this problem ?

Thanks you

Best regards,


@rayanebel how did you get past this? I am facing a similar issue

@justinhauer , @rayanebel
You could set env DRONE_SERVER_PORT :8080 into your deployment

One should never need to change the server port since Drone is binding to the port inside the container. In this case, it ended up being security group issue with kubernetes / rancher. See this thread for more details Helm Deploy Errors - Github Enterprise

interrupt received, terminating process

This error message indicates something external to Drone is sending the container a SIGINT or SIGTERM which is in turn shutting down the Drone server.

anyone knows what to do in openshift 4 for this error that @bradrydzewski mentionned?

The solution to this issue was to not name the container drone-server, which in turn prevents Kubernetes from injecting an environment variable named DRONE_SERVER_PORT