UI buttons don't work - Secrets and Cron Jobs tabs in repostiory settings don't open in UI

I am running community (OSS) version of Drone (2.1.0) and it runs well. The only issue I have is the Secrets and Cron Jobs tabs in the Settings menu for any repository. When I click on any of these two items the UI just becomes blank and even going back doesn’t change anything - I have to refresh the page. I tried using version 1.10.1 and it works fine (different UI so doesn’t apply, but still). I don’t have any other issues with Drone, only buggy UI for those two items.


I am unable to reproduce. Do you have an error message in your console that you can provide the Drone maintainers to help them debug?

@bradrydzewski thank you for your reply. I am getting the following error in browser when I click Secrets (I clipped out domain name):

Same for Cron Jobs. Is this because Secrets and Cron Jobs are not implemented in the OSS version? Version 1.10.1 has those options active, though I haven’t tried using them.

Hi @georgebv,

Yep the problem here is that the OSS version does not have repo secrets or Cron jobs.

We will look into disabling these options for OSS at some point in the future :slight_smile: