SSH clone: skipped

I installed and configured drone with two runners docker and SSH. All build steps are run correctly on docker, whoever for ssh runner I’m getting ssh - clone: skipped.

My .drone.yml is as follows:

kind: pipeline
type: docker
name: default

  - name: echo branch
    image: alpine
      - echo ${DRONE_BRANCH}

kind: pipeline
type: ssh
name: ssh

  host: ******
  user: ******
    from_secret: ssh_key

  - name: deploy-app
      - echo ${DRONE_BRANCH}
      - ./  ${DRONE_BRANCH}

I’m using docker-compose to setup server and runners and both runners are sharing same file with: DRONE_RPC_SECRET, DRONE_RPC_HOST, DRONE_RPC_PROTO

What I’m doing wrong?

Apologies, I uploaded the wrong screenshot.
Here is the one with error visible:

I found out that the clone: skipping issue was caused by using secrets in build step. In fact I’m not able yet to properly use secrets in drone.
For SSH it caused “clone: skipping” and docker plugin fails on registry login if I use “from_secret” notation.