[solved] Upgrading drone-docker-runnner from 1.5.2 to 1.6.1 makes pipeline with parallell docker plugin step fail

It looks like only the step that started first works.

latest: Pulling from plugins/docker
Digest: sha256:60f36379eb3f1b27a61f7c0a275dd260387a00af1144345976475b2a35e5ee4f
Status: Image is up to date for plugins/docker:latest
+ /usr/local/bin/dockerd --data-root /var/lib/docker --host=unix:///var/run/docker.sock
Detected registry credentials
+ /usr/local/bin/docker version
Client: Docker Engine - Community
 Version:           19.03.8
 API version:       1.40
 Go version:        go1.12.17
 Git commit:        afacb8b7f0
Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?
 Built:             Wed Mar 11 01:22:56 2020
 OS/Arch:           linux/amd64
 Experimental:      false
time="2020-12-05T17:11:40Z" level=fatal msg="exit status 1"

restarted the same build a few times with the same error every time. Other pipelines with single docker steps did not fail. After reverting to the old docker runner the same build started working again.

I just tested and can confirm parallel docker plugin steps work fine with 1.6.1. Perhaps you can post a complete yaml that can be used to reproduce and we can advise further?

The only notable change that could impact the docker plugin is you can no longer mount volumes. If you attempt to mount volumes the plugin no longer automatically runs in privileged mode, in which case you need to manually add privleged: true.

it’s probably because of volumes… I’ll try to upgrade again and take a closer look at those settings.

That was the issues… I guess a better error message instead of an cryptic docker not starting error would be a lot better. As an example I had no idea that the docker plugin even requires privileged mode (because I don’t remember it) in the first place and from what I can tell the documentation for it (http://plugins.drone.io/drone-plugins/drone-docker/ ?) does not specify it either.

glad to hear you got it working. you’re welcome.