[solved] Trouble running my deploy step with drone 0.4

Hey all.
Apologies for what is probably a stupid question but I’m relatively new to drone (and web dev in general). My goal at the moment is to call a few functions in my project’s fabfile.py in order to update my ec2 staging instance (create a snapshot, etc). My current drone.yml:

      - fab test

(all “test” does at the moment is print to the command line):

My build keeps failing however, with the following error:
[info] Pulling image plugins/drone-script [error] Error pulling plugins/drone-script. Not found

I’m not too familiar with drone to be able to discern exactly what’s going on but it looks like drone is looking for a plugin named script which obviously doesn’t exist. I’ve tried:

        - fab test

and several variations, all of which produce a similar error. Obviously I’m missing some key concept on how the deploy section is supposed to work. Just wondering is anyone could give me some insight on how best to do this. Thanks so much.

This is an example of a deployment for drone 0.4 (the version you are using)

    app: awesomeness
    force: true

The above code indicates the heroku plugin should be used. The heroku plugin is an official plugin documented at http://readme.drone.io/0.4/plugins/heroku/

The examples you provided above would instruct drone to use a bash or script plugin. No such plugins exist, which is why Drone cannot download them automatically.

The 0.4 documentation is archived at http://readme.drone.io/0.4/ and the plugin documentation can be found at http://readme.drone.io/0.4/plugins/

If you just want to run a bash script, I would recommend just adding a second step to your build section as described here: http://readme.drone.io/0.4/usage/build_test/#multiple-steps

Note that you can limit build step execution based on branch and other criteria as described here: http://readme.drone.io/0.4/usage/build_test/#conditions

I should also clarify that the deploy section in 0.4 can only execute plugins. This ended up not making much sense which is why the deploy section was removed in drone 0.5 in favor of a single pipeline section. The 0.4 version is now deprecated, so to take advantage of advancements in the platform you’ll want to consider upgrading to 0.5

Hey Brad,

Thanks so much for the reply. I’ve switched over to 0.5 to give it a try
but I’ve noticed that, unlike 0.4, the dashboard no longer provides
terminal output of my builds. Just wondering if there is anything I can do
to gain insight into the build as it’s running. For clarification, I’ve set
up a drone server on an ec2 instance.

Again, I really appreciate your time.

The terminal output from 0.4 is in a legacy format, and cannot be rendered in the 0.5 user interface. New builds will store logs in the new format and are rendered without issue.