[SOLVED] Missing Drone logs

Looks like one of my builds isn’t saving build output logs to postgres. When I watch the build in real time, I see the logs coming through just fine, but when I go back to a completed build, the logs for the clone step are there, but the build step’s logs are nowhere to be found.

When I try to get the logs from the Drone CLI:

$ drone log view <repo redacted> 148 1 2
client error 404: {"message":"sql: no rows in result set"}

The .drone.yml file has two concurrent pipelines, one for Linux and another for Windows. Both pipelines are being run using the Docker runner. The Windows build logs show up just fine, linux’s are missing.

the most common root cause we see for logs not being uploaded and saved is when there is some sort of reverse proxy, load balancer or other network configuration that limits the size of http requests. Log files can exceed 5mb, and if there are http request limits in place it can cause log uploads to fail. The fact that it works with windows but not linux could indicate the linux logs are just slightly more verbose and are exceeding the limit.

1 Like

Thanks for the quick reply! Once my hosted Kubernetes provider un-breaks my cluster’s control API, I’ll test it and post the results.

That fixed it, thanks for the help!

For anyone who stumbles into this thread from Google using NGINX’s ingress, add this annotation to your Ingress resource:

nginx.ingress.kubernetes.io/proxy-body-size: 8m