[SOLVED] How to enable privileged mode on docker 1.x

I was trying to enable privileged mode on docker 1.x. On the web page protected checkbox is disabled, and I’ve also executed docker repo update <repo> --trusted=truebut the linter still throws an error ( linter: untrusted repositories cannot enable privileged mode )

I’ve also tried to set different environment variables like DRONE_REPO_TRUSTED, DRONE_GITHUB_PRIVATE_MODE, DRONE_RUNNER_PRIVILEGED_IMAGES but none of them worked.

I’m forgetting something?

What version of Drone are you using? If you are using Drone 1.0.x please see my comment here. Only a trusted repository can use privileged mode (the checkbox must be checked) and only a system administrator can mark a repository as trusted.

Thank you very much for the fast response. Indeed, that was the missing piece :slight_smile: