[solved] Gogs hook doesn't work?

I’m try latest drone, and gogs / 0.11 RC
But not working. Drone doesn’t build, no error in logs…

ok my local pc (other computer) show this log:
drone-server_1 | time=“2017-03-30T22:21:02Z” level=error msg=“failure to parse token from hook for ondrej/xz signature is invalid”

I am running Drone+Gogs / 0.11 RC without issue.

But not working. Drone doesn’t build, no error in logs…

Did you look at the Gogs logs? What about the hook history in the Gogs user interface which lets you see the hook response and error message?

The common reason for Gogs hooks not working is people trying to hook Gogs up to Drone using localhost. When Gogs runs inside a container and Drone runs inside a separate container, they have isolated networks, which means localhost cannot be used.

This is most certainly a networking issue. Make sure you use an IP or DNS when you configure Gogs to work with Drone. Also consider searching through the discourse history. I think this question comes up frequently and there should be plenty of discussion and example configuration options you can use.

many thanks, in Webhooks gogs i solved this problem :wink: