[SOLVED] ERROR: Insufficient privileges to use volumes


Sorry for my bad english.

I use drone 0.4.2 for a long time, but I upgrade this to 0.5.0. Server-agent system is good but after a lot of solved problem, i can’t solved this.

I explain, I use drone for build and push my own images on dockerhub, for this I use this .drone.yml :

    image: xataz/docker-client:1.13.1
      - /var/run/docker.sock:/var/run/docker.sock
      - /home/xataz/.docker/config.json:/home/docker/.docker/config.json
      - UID=1000
      - GID=991
      - chmod +x build.sh
      - ./build.sh push

this works with drone 0.4.2, but no with drone 0.5.0, I have a error :
ERROR: Insufficient privileges to use volumes

Can you help me ?

Thanks and regards,

I solved myself.

My repos isn’t trusted, but add trusted by UI don’t works. I add this directly on database.

Now it’s works.


1 Like

The trusted flag in the user interface can only be toggled by a Drone system administrator. Instructions for configuring the list of Drone system administrators can be found here http://readme.drone.io/admin/user-admins/ … I can confirm that when configured properly this works as expected.

1 Like