[solved] Attempt to enable repo on older Bitbucket servers fails

When trying to enable new repo for old Bitbucket server(v6.10) Drone fails with following error:

There was a problem enabling your repository.
the event pr:from_ref_updated is unknown.

Current workaround is:

  1. downgrade to Drone version 1.8
  2. enable the repo
  3. upgrade back to recent version

I think it would be better that instead of an error, you get a warning that you might have limited capabilities due to unsupported feature in your VCS.

The error comes from bitbucket server which means we cannot issue a warning. Instead we would have to enhance Drone with the following:

  1. Drone would need to allow you to configure the version of Bitbucket server when you setup your Drone server (e.g. DRONE_STASH_VERSION=5.x.x) and;
  2. Drone would need to gracefully downgrade API requests to work with older versions of Bitbucket server. Specifically, if you are using Bitbucket Server 6.x or below, Drone would omit pr:from_ref_updated when creating webhooks.

For now, your best option is to run Drone version 1.8 in production, since this change will take some time to design and implement. We will add this to our roadmap and update this thread once we have progress to share.

1 Like

Thank you for looking into it. I guess I’m stuck with an old version…

I’ve currently started on implementing a solution for the versioning.

1 Like

Hallo @bakito , is your implentation now part of the current pre-release version of drone 2.0? i made a test with a bitbucket 5 today, but i stll got the error

Hi @geopossachs
Unfortunately not. Drone still uses drone-scm v1.8 which is a cersion before the merged PR.
I’m still waiting for 2 other PR’s to be merged, which I’d need for bitbucket 5 Integration.

Hallo @bakito
Thank you for your work. I tried it and now bitbucket5 is working with drone2, that’s just wonderful :slight_smile:

1 Like

I can confirm it works now. Thank you @bakito!