Shell runner Path problems


in order to deploy a tool on a remote host, I use the shell runner. it works fine in general, but sadly I run into some trouble executing some commands, more specifically pipenv. Its always complaining the exe cant be found or if I specify the absolute path, some python modules cannot be found:

/home//.local/bin/pipenv --version
Traceback (most recent call last):
File "/home/
/.local/bin/pipenv", line 7, in
from pipenv import cli
ModuleNotFoundError: No module named ‘pipenv’

So I was curious and tried to find out which shell I am running:

echo $0

I am not sure, how to proceed. I expected Drone to just log in to my user and use the local environment in order to run commands. For some reasons this seems to be not true. Do I have a wrong understanding of how it works? Or is the problem caused by some weird special setup I did?

I am happy about any input, thanks in advance!


the purpose of the ssh pipeline runner is to execute an entire pipeline (clone repository, execute commands, etc) on a remote machine using the ssh protocol. If you want to ssh into a remote machine and execute a few commands, as opposed to execute an entire pipeline, perhaps you instead want to use the ssh plugin with a docker pipeline?

1 Like