Set up secrets in Drone return empty value

'm trying to setup secrets in Drone but without any luck. A simple operation like adding a secret doesn’t work for me. I’ve tried in several ways but no result.

I’m running Drone 0.5.

this is what I run:

drone secret add --skip-verify=true org/my_repo PRIVATE_KEY @/Users/me/.ssh/my_key.pem

the result is this:

        "conceal": false,
        "event": [
        "id": 30,
        "name": "PRIVATE_KEY",
        "skip_verify": true,
        "value": ""

Any idea?

Please note that 0.5 is end of life, so support will be limited. Usually we see this issue when you have https enabled on your server with automatic redirect, but you configure the CLI with the http address. So the first tip would be to make sure you are using the correct address, with https, if applicable. Also make sure you are using the 0.5 CLI since newer versions of the CLI may not be compatible with older versions of the server.

I’ve solved by setting as env variable DRONE_ADMIN my username and furthermore I’ve notice that although the secret is set, the field value is still empty. I guess this is by design wanted to prevent to read the secrets