Runner pod network

I would really appreciate your help in understanding how the runner pod networking works.
About our environment:

  • Running on eks cluster
  • chart: drone-runner-kube
    version: 0.1.8
  • later updated to version 0.1.10 but still no helps
  • chart: drone
    version: 0.2.5

The Background:
I am trying to build a docker image within drone custom step created at our own company (connected with a volume to docker sock) with the following command-
docker build . -t ${IMAGE-NAME}

Dockerfile example:
RUN npm i -g release-it npm-check-updates

The issue:
when the step is running, we are having network issues with the ‘npm i’ command (this is only example, had it also with different apk add commands) with the following error:

npm ERR! code EAI_AGAIN 157s
23npm ERR! syscall getaddrinfo 157s
24npm ERR! errno EAI_AGAIN 157s
25npm ERR! request to failed, reason: getaddrinfo EAI_AGAIN

same step with other Dockerfiles that are not trying to download external components works perfectly.
Also, same dockerfile mentioned here works with plugins/docker step.

Basically, I am trying to understand how Drone network works and how it run the containers steps to see what can cause network issues for me such as getaddrinfo.
Couldn’t find it in the documentation, can you please help?

Thank you

@natali closing this loop as they are sorted. Thanks!

Hey @Shruthikini,
Thanks for the answer but I didn’t understand.
what does it mean? Do you know any way I could make ‘docker build’ with installations inside the Dockerfile to work?

Sorry if it not relevant

@natali closed this loop as you have mentioned you got some help here: Drone server not starting, stuck after "starting the zombie build reaper"

Let me check some solution for this and get back to you.


Hey, those are two differnet issues, it is not relevant to upgrading drone like the other issue mentioned above

@natali got it! give me some time to get back to you on this.


1 Like

@natali Sharing this in general: Understanding kubernetes networking: pods | by Mark Betz | Google Cloud - Community | Medium

Some docs around k8 runner-

  1. Overview | Drone

Here is a link that will help you understand various scenarios around your question.

Let me know if these docs are useful and you can write questions you need answers specifically.


I managed to solve it and it actually had nothing to do with Drone, so sorry I bothered you.
Writing my solution in case someone else will have the same issue too:
In my case, it was the docker socket network who caused the issue, solved it with running ‘docker build --network host’ instead of default.

Thank you!

@natali Glad that you were able to figure out the issue. Do not hesitate to reach out for any questions :innocent: