Repo Update API - inconsistent naming?

While looking at the API docs to update a repo, I realised that the example request payload is wrong: the fields allow_deploys and allow_tags have to be named allow_deploy and allow_tag, for the call to work.

However, the output returned after a successful API call contains, in fact, allow_deploys and allow_tags in the payload. :face_with_raised_eyebrow:

I was about to submit a PR for the docs, but because of this inconsistency between the two payloads I’m not sure what the intended names are. Is someone able to clear this up?

The Input and Output are different Go structures and as you mentioned, have an inconsistent naming for a couple of fields. You can see this illustrated in the Go API https://github.com/drone/drone-go/blob/master/drone/types.go#L15:L51

I see. Would it be better if I just submitted a PR to update the docs, then? Updating the API would definitely have farther-reaching consequences.

Yes, a PR to update the docs would be great. Those fields will go away in 0.9 so probably just makes sense to keep the status-quo and avoid any breaking changes until 0.9 is available. Thanks!