Plugins/docker: x509: certificate signed by unknown authority

The push refers to a repository []
Get x509: certificate signed by unknown authority
time="2017-05-26T06:48:34Z" level=fatal msg="exit status 1" 

Things I’ve tried:

  • I’ve already set insecure: true for plugins/docker.
  • I’ve mounted a volume with my ca-certificates.crt at /etc/ssl/certs.
  • I’ve set env variables on the drone server/agent of DOCKER_TLS_VERIFY=0

Any other ideas?

the plugin has an insecure: true parameter that you can set. For a full list of parameters you can see

I tried that, first bullet point of what I tried. Didn’t work. I put insecure: true in the .drone.yml of the project I’m trying to get working.

I recommend building and testing locally. The codebase is quite small and it should give you the ability to try different daemon configuration options. If you find something you can send a patch. Note that plugin can be run in standalone mode (see the README) which can simplify local testing.

The plugin repository is located at

Thanks @bradrydzewski local testing allowed me to figure out that I had mis-configured my .drone.yml.