Pipeline steps run unexpected

Hello everyone,

I have builded drone plugin with following Dockerfile:

FROM alpine:3.6
ENTRYPOINT echo “This is sparta” && /bin/sleep 3

I used it in pipeline:

image: drone/plugin

image: node:8.7.0
- npm install

next step in pipeline is triggered before first executes like they are in the same group.

Is there any specific thing that plugin should do for waiting until the end of ENTRYPOINT ?

drone steps are guaranteed to run sequentially, and will wait for the prior step to execute. It is therefore likely a configuration problem with your yaml file, however we need to see a complete working example that can be used to repeat the problem. Without a complete working example, it is really hard to debug.

It is also possible you are running an old version of drone, and are not taking advantage of the latest set of yaml improvements. Please also include your drone version number in reports.

Hello bradrydzewski,

Example that I have been provided to you is full version and we have tested pipeline from it.

It is strange that if we run unix commands from ENTRYPOINT as commands in pipeline everything works fine.

Drone version which we use is 0.7.

We tried with 0.8, but our pipeline is not triggered every time and we have not much time to troubleshoot further.

As addition, i suppose that is not problem with pipeline.

There is some problem on triggering and working with plugins that we created in bash with tutorial:


Plugin is triggered and not finished when other step started.

Is there something that should be added when creating plugin on that way?

The problem in this example is that your pipeline step does not have any parameters or commands. In 0.7, drone will interpret this as a service (like mysql) and will daemonize the step. This was fixed in 0.8. This was the relevant issue https://github.com/drone/drone/issues/2124

This tutorial is from drone 0.5 and is not longer a valid configuration. Please do not use.

We tried with 0.8, but our pipeline is not triggered every time and we have not much time to troubleshoot further.

0.7 was an unstable release and should be considered end of life, without support. I recommend expediting your upgrade to 0.8 stable so that you can take advantage of the numberous improvements and 30+ bug fixes.

Thanks for advice.

That is what we wanted.