Parallel build with npm install fail with weird messages

Using drone 0.8-rc.3
Build image node8.0-alpine

Trying to use two parallel build jobs that npm install throw me out on strange errors:
“npm ERR! enoent This is related to npm not being able to find a file”

When run alone, or one by one I don’t get this.
Tried to use different npm tokens did not help.

Any idea?
Anyone tried this?

Follow up questions:

  • Have you googled the error to get more information? Can you summarize findings?
  • Does your post above include the full error message? Any extra error lines that could be useful?
  • Have you looked at the npm-debug.log for more information? Anything useful?
  • What does your .drone.yml and package.json look like? It is critical to see this information to help debug.

When I see this error my first thought is that:

  • You are hitting some sort of host machine os limit, such as a file descriptor limit
  • You are using a shared volume or cache in your build configuration that could be subject to races or corruption? Providing your .drone.yml can help rule this out.

I would also suggest asking this question on stackoverflow which will have more npm and docker experts available to answer your question.

I will need to see your yaml to be certain, however, I do not believe there is anything we need to troubleshoot at the drone level, since drone is just starting docker containers and collecting the output using a series of commands, like this:

docker volume create workspace
docker run --v workspace:/drone node /bin/sh -c "git clone http://... /drone"
docker run --v workspace:/drone node /bin/sh -c "npm install"

First of all, you’re 100% right. I left no helpful data, sorry for that.

My problem was trying to npm install concurrently which is obviously impossible within a shared workspace.
Will be more informative in the future.
Thanks for the reponse.