New phone and cannot login via 2FA - not admin account

I enabled two factor authentication for my Harness login (on an iPhone) and got a new phone (also iPhone) over Christmas without remembering to do anything about 2FA for Harness. I am not the Harness admin. I cannot login as I need to provide the (6?) digit authentication code. How can I regain access to my account? If it’s something the admin needs to do, can you provide any specifics around that process as well?

I thought I had this setup in the DUO app but it turns out Apple has the authenticator built into the password page. Having found that I now recall THAT’S how it was setup originally. I initially thought it was great that Apple seems to have carried this over to the new phone…perhaps though iCloud?

But…I have tried the 6 digit code several times and I cannot login. It says the code is invalid despite having several seconds left on the authenticator count down. I’ve tried having the password/authenticator side by side with a browser at the login page. When the authenticator code flips and the 30 second count down restarts, I then reload the login page, enter my email and password, click login then type in the EXACT 6 digit code. No dice. Every code is invalid. Maybe the carry over to the new phone doesn’t actually work.

So I’m still stuck. Can anyone help?

I also recognize posting this on a Friday night is much less likely to garner a response. :slight_smile: Hope everyone is out enjoying themselves.

I contacted our devops admin who had to reach out to Harness and followed this process:

In IOS you first remove the 2FA code in the passwords screen. Then click the item below to add it back in using the QR code from the reset email.