Missing python sysconfig pakcage

Hi, my project builds fine in dev environment, but when I throw it into a drone CI docker image it gives me the following error:

-- pybind11 v2.6.2 dev1
-- Found PythonInterp: /usr/bin/python3.6 (found version "3.6.9") 
CMake Error at python/pybind/tools/FindPythonLibsNew.cmake:131 (message):
  Python config failure:

  Traceback (most recent call last):

    File "<string>", line 1, in <module>

  ImportError: cannot import name 'sysconfig'

Call Stack (most recent call first):
  python/pybind/tools/pybind11Tools.cmake:38 (find_package)
  python/pybind/tools/pybind11Common.cmake:201 (include)
  python/pybind/CMakeLists.txt:169 (include)

I tried building directly in the docker image and it also builds fine. I tried importing sysconfig in the python REPL and it also worked. Any idea what’s causing this?


When you manually build in the docker image do you also install python3-distutils separately? Is it possible python3-distutils might be missing in the runner step?