How to bind private registry host with LAN ip?

Hi :hugs:
I got a problem that the [add_host] field does not work at all.
I want to push my image to a private registry(harbor). The LAN address range is 192.168.2.X .

Here is the drone.yml:

kind: pipeline
name: test-ci
type: docker
  - name: docker
    image: plugins/docker
      no_cache: true
        from_secret: harbor_username
        from_secret: harbor_password
      insecure: true
      tags: v0.55
      event: push
      branch: master

Here is the log:

latest: Pulling from plugins/docker
Digest: sha256:ac5176110e7378320447551854a12aefdfb757dda1e59d29cecae7f1e729e0a6
Status: Image is up to date for plugins/docker:latest
+ /usr/local/bin/dockerd --data-root /var/lib/docker --host=unix:///var/run/docker.sock --insecure-registry
Detected registry credentials

Error response from daemon: Get dial tcp 58.XX.XX.XX:30443: connect: connection refused

time="2021-09-21T02:01:58Z" level=fatal msg="Error authenticating: exit status 1"

You can see that “” is redirect to an external IP(this external ip is mine) which is not the ip I 've set( I also tried [custom_dns], but it doesn’t help.
It confused me, or maybe its not the correct way to use [add_host] ?
Can someone give me some suggestions? Many thanks :blush: