[GITHUB PROVIDER] TypeError: Cannot read property 'timeStarted' of undefined


I tried to connect Drone:2.0.1 to GITEA and everything worked fine. I then connected the same instance to GITHUB (changed git provider).

Could login through OAuth or sync my github repos fine.

But I cannot open a build page (or repo page when build is ongoing) without having below error thrown in the Chrome console:

TypeError: Cannot read property 'timeStarted' of undefined
    at main.cb7f5b7a.chunk.js:1
    at main.cb7f5b7a.chunk.js:1
    at Object.useMemo (2.57de3aee.chunk.js:2)
    at t.useMemo (2.57de3aee.chunk.js:2)
    at mo (main.cb7f5b7a.chunk.js:1)
    at ia (2.57de3aee.chunk.js:2)
    at Hu (2.57de3aee.chunk.js:2)
    at Es (2.57de3aee.chunk.js:2)
    at Os (2.57de3aee.chunk.js:2)
    at Ss (2.57de3aee.chunk.js:2)

The page becomes blank (page’s url looks like this > https://drone.my.domain/org_name/repo_name).
Any idea?

Thanks a lot for your help!

Note: I tried using the admin AND a non-admin user. Both throw the same error.

Note 2: deleted the db file from inside the container, then let drone recreate /data/database.sqlite. Launched a build. Same error.

Note 3: Triggered a build on another repo (within the same org). Same blank page/error

1 Like

I can reproduce the error on https://cloud.drone.io

My .drone.yml file looks like this:

kind: pipeline
type: kubernetes
name: default

  - name: publish
    image: plugins/docker
      username: nologin
        from_secret: registry-token
        - latest
        - ${DRONE_TAG##v}
        - tag

  - dockerconfig

The problem is related to the “first build” (probably similar to this issue)

I fixed it by manually restarting the 1st build, through the CLI (hence creating a #2 build)thun:

drone build restart my-org/my-repo 1

I have the same problem while having connected Drone to Bitbucket. Downgrading to 2.0.0 does not solve this issue. Also having a second build does not change the error I get when accessing http://drone-server/FOO/bar. Though I can access the builds directly: http://drone-server/FOO/bar/1

Maybe related to Drone 2.0 - Opening some build status pages leads to white screen

My problem was: the drone-runner was not running, so no builds were executed. Now the error is gone and I can access http://drone-server/FOO/bar without any problem.
I still think that this error (white page) should not occur, even if there are no builds running/finished.

same problem as me. .

same problem in cloud.drone.io