Gitea Configuration Broken

Hello there,

I have tried running in a docker container but it wont work at all with gitea in the latest 1.0.0 release.

docker run \
  --volume=/var/run/docker.sock:/var/run/docker.sock \
  --volume=/var/lib/drone:/data \
  --env=DRONE_GITEA_SERVER=https://git.*****.net \
  --env=DRONE_GIT_ALWAYS_AUTH=false \
  --env=DRONE_SERVER_HOST=ci.*****.net \
  --env=DRONE_SERVER_PROTO=https \
  --env=DRONE_TLS_AUTOCERT=false \
  --publish=8010:80 \
  --publish=8020:443 \
  --restart=always \
  --detach=true \
  --name=drone \

The CI is running behind a reverse proxy by the way, thats why the ports are different.

When trying to create an admin account using

docker run -e DRONE_USER_CREATE=username:JustinBack,machine:false,admin:true 89752c9cb739

after the container has started it just says

	"level": "fatal",
	"msg": "main: source code management system not configured",
	"time": "2019-04-22T09:01:00Z"

The run commands are straight from the docks so the build must be broken.

Well it seems to work now. However a repository suddenly went missing on

After logging in I was able to activate it, resyncing caused it to completely disappear, even after syncing again. Can manually call it via URL however its weird…

Already tried:

drone repo chown JustinBack
drone repo sync
drone repo update *REPONAME*