[fixed] Templating with yaml is not working

Hey. I created a template and added it by:

drone template add --namespace repositoryName --name validate-plan.yaml --data @validate-plan.yaml

then when I run

drone template ls                                                                                                                               

it returns:

  validate-plan.yaml 33m%   

^ what’s 33m% ?

and then when I run:

drone template info --namespace repositoryName --name validate-plan.yaml

it returns:

validate-plan.yaml 33mtemplate: _:1:30: executing "_" at <.Namespace>: can't evaluate field Namespace in type *drone.Template

What’s wrong?

Someone had previously reported an issue but I think it was resolved, so you may just need to upgrade to a newer version of the CLI Drone hangs when using templates

@eoinmcafee00 can you confirm this template error was fixed ?


This is a valid issue which I’ve now fixed in fixes issue where template info command wasn't working by eoinmcafee00 · Pull Request #203 · drone/drone-cli · GitHub

Thanks @eoinmcafee00 !

@Upgreydd this has now been fixed if you pull the latest.

thanks mate! :slight_smile: Nice work :+1: