[FIXED] Drone 2.0 - UI shows white page and "TypeError: i is undefined"

Just saw the aweseome Drone 2.0 announcement and did a test build (go build -ldflags "-extldflags \"-static\"" -o drone-server)

Login works, but afterwards JS console throws an error and there’s only a white page.

Tried some different working urls:

  • project settings
  • project deployments
  • project branches
  • single build (selected from branches tab)

The build overview of a project throws the same error

Aha…another test using my admin user works for almost all routes. Project overview still is a white page.

So it looks like the error occurs for unprivileged users only.

Unfortunately I cannot reproduce and the JS output is not super helpful since it is minified. We will post a thread over the weekend that describes how to build the UI from source and run it locally in debug mode, which will help with reporting issues.

Thank you. I’ve already tried with the instructions from the drone2 branch here: GitHub - drone/drone-ui at drone2 which still gave me the “old” ui :wink:

Ah, funny, just tried another user (which has never been logged on to drone) just works without any errors…probably something with my account?

Current errors for admin user on project view

TypeError: Cannot read property 'charCodeAt' of undefined

Dropped my entire database and started from scratch without an admin user, the dashboard works.

Project build overview throws another one TypeError: Cannot read property 'duration' of undefined

I came here to report the same issue. It is reproducible on firefox v85 and chrome v89 for linux.

I am using the free cloud.drone.io hosting for an open source github project. Projects I have CI/CD setup for from before the 2.0 rrelease load successfully.

Since the JS code is minified there isn’t much I can’t provide much besides the current project I have seen this issue on.


If there is any additional information needed, please let me know.

1 Like

Good to Know i`m not alone =)
let us know how we can help !

1 Like

thanks for the report. this has been patched and redeployed to drone cloud, and there is a new docker image available.

1 Like

This Type of Error is solved =)
Maybe next Topic for this ?

this was fixed patched earlier today [1], however, the latest version of drone has not been deployed to drone cloud yet. I am going to close this thread since the primary issue was resolved. Feel free to create new / separate threads for new issue reports.

[1] ensure correct last started date when build count is 1 · drone/drone-ui@ed66040 · GitHub

1 Like