Failed to unmarshal Stringorslice

I installed drone on a fresh digital-ocean dropplet (2GB, debian 9.3) by installing docker (17.12.0-ce) and docker-compose first. After that I created the docker-compose.yml file with the content of: I changed the secret, github-key and github-client variables and started it with docker-compose up.

I am able to select the repository of my choice. In this case a fork of your python-demo: After pushing a dummy commit, drone “starts” the build. But it fails with the error “Failed to unmarshal Stringorslice”. Sadly I am not able to see any helpful messages in the logs. My guess indicates that this error comes from parsing some yml file…

Can you guide me on how I can debug this further? Did I do something obviously wrong?
(I tried it with bitbucket-cloud, older / newer versions of drone, drone via rancher-catalog, different project with simpler .drone.yml file…)


This error would indicate your Yaml file is malformed and cannot be parsed. Please provide a copy of your Yaml and I can advise further.

Thanks for your quick answer.

Are you talking about the .drone.yml file?
As I am using the drone-with-python repo-fork:
I also tested it with my drone-test repo:
=> Both have the same error.

The yaml file at this link is invalid:

It appears to use an outdated version of the .drone.yml format which was deprecated a few years ago. You will need to update the Yaml to use the latest format, as described here:

Thanks! I knew it had to be something obvious. I was to focused on this drone-with-python demo to see that the syntax in the doc had changed.

Thanks again