Execute job right now


I can add scheduler for my repository for example for 1 hour and its ok. But how can i run my new project right now? I can restart it but i can not run fresh project.

get started by:

  1. activate your repository in the Drone user interface
  2. create a .drone.yml for your repository
  3. commit and push

when you push code, your source control management system (e.g github) will send a webhook to Drone to trigger a build.

  1. Imported, cloned. I see example repo in my drone.
  2. How? Where? Into ubuntu or where?
  3. How?

Can you please give me a small / short instruction about point 2 and 3. Im newbie. I have a drone server in ubuntu via docker and sample repositories inside. Please tell me how can i create drone.yaml file, where can i put this and how i can push it for new build.

We provide a quick start in the documentation:

And you can read more about docker pipelines here:

There are also some great community tutorials that you can use:


For example:

I maked everything to this line:

Defining build steps and pipelines in Drone is a simple process. Just add to your repository .drone.yml file and use yaml syntax to describe the steps. Here’s a simple example:

  1. Where can i modify and Where is my drone.yml file? In linux? In github? I copied repository from github to drone and i see it. I also see in settings the drone.yml file but where is it? Where can i find this file and how can i push it to new build?

“The final step is to commit your .drone.yml to your repository and push your changes. When you push code, GitHub sends a webhook to Drone which in turn executes your pipeline.”


I still dont know where is the drone.yml file and how to push it. I have github account and sample repo which i copied to drone.

From this tutorial i https://dev.to/alex_barashkov/getting-started-with-open-source-drone-ci-4pgc i done everything to this line

Defining build steps and pipelines in Drone is a simple process. Just add to your repository .drone.yml file and use yaml syntax to describe the steps. Here’s a simple example:

Where can i modify drone.yml file? In github account? How can i push it? From github website? Please help me. I dont know how to pushing it and where can i modify this file.

Where can i modify drone.yml file?

The .drone.yml file is stored in the root directory of your git repository. You modify the file the same way you modify any other file in your repository … you open your favorite text editor, make changes to the file, and save it.

How can i push it?

git has a command called git push that you use to commit changes to your local repository, which you can then push to the repository in github

git add .drone.yml
git commit -m "added my drone yaml"
git push origin master


I download repo from the github to local server with drone

When i changed and pushed:
kusus@skynet:~/test/droneci$ git add .drone.yml
kusus@skynet:~/test/droneci$ git commit -m “added my drone yaml”
[master 4478452] added my drone yaml
1 file changed, 1 insertion(+)
kusus@skynet:~/test/droneci$ git push origin master
Username for ‘https://github.com’: Skynet886
Password for ‘https://Skynet886@github.com’:
Counting objects: 3, done.
Compressing objects: 100% (3/3), done.
Writing objects: 100% (3/3), 322 bytes | 322.00 KiB/s, done.
Total 3 (delta 2), reused 0 (delta 0)
remote: Resolving deltas: 100% (2/2), completed with 2 local objects.
To GitHub - Skynet886/droneci
f3bf6d0…4478452 master → master

But i dont see anything from the drone website, where is that?
I have a drone as localhost

After push i dont see my changes and nothing from the drone side.

GitHub cannot deliver webhooks to a local address of GitHub can only deliver webhooks to public addresses. You therefore would need to publicly expose your Drone instance using a public IP or public domain name that is reachable by GitHub.

This is also covered in our FAQ at Nothing happens when I push code, no builds, or builds stuck in pending

Ok, but…

1 screen - my configuration

I run docker via:

sudo docker run

where is my ip addr

When i start this my drone response from the

If i try open it automatically redirect me to and i have some error cookies…

because you need to update the oauth2 redirect URL to reflect your new address [1]. You should probably also clear your browser cache to remove old cookies that may be associated with the old address.

[1] GitHub | Drone

I repaired it.
So i pushed small change from git

I have changes and i see it in repos in git:

But i can not see anything in drone… hehe… Its steel death.

As previously mentioned you need to use a public address or domain name, otherwise GitHub cannot send a webhook to your Drone instance to trigger a build. It looks like you are using or which are both private addresses. Neither of these addresses are reachable by GitHub which prevents GitHub from triggering builds on push.

If you continue to experience issues you will need to use this guide for further assistance: Nothing happens when I push code, no builds, or builds stuck in pending