Error Logs Debug

Trying to Deploy a simple workflow on GKE, using Git/Source helm chart, Docker/hub nginx image.
The console shows ‘Deploy Failed’ - but does not describe the error. Tried drilling down the boxes nothing. I think I have provided right permissions to the service account - per documentation.

What could be likely causes, how do I debug this - are there any log files I can look at.


Happy holidays!

Could you provide some more details here?

  • Some screen caps and details of your Pipeline / Workflow.

  • What version of Helm do you have running?

  • What’s the Chart URL / Repository?

  • What Delegate are you using? Eg a K8s Delegate you deployed to GKE?

You left EKS ha!



Helm version v2.15.1

K8s Delegate – standard yaml delegate

Repo: GitHub - Sam-SFO/harness-helm: Harness Helm


Can you expand all the steps?

Also can you show all your wiring.


This is best screen shot I can come up with

Cloud the issue be with how I have setup Tiller. The documentation is not clear on this.
I am assuming Tiller has to be installed, I had setup with helm init , rather than with associating tiller with the service account - rbac. I had used the service account when I setup the GCP cloud provide - as the documentation had suggested.


Hope you had a great Thanks Giving and learned about the wonders of Tiller :slight_smile:

For your workflow, if you expand the + under Rolling, might give you more insight.
Here for example I had induced a failure on a Canary.

We have two types of deployments that can leverage Helm; one that requires Tiller and one that does not.

Typical trouble shooting:



I see the error in rollout - no chart.yaml ??
I do have chart.yaml harness-helm/harness-test at master · Sam-SFO/harness-helm · GitHub


Helm is really picky about the structure / convention. Imagine like back in the Maven days. Not sure if there is something off on your packaging.

I’ve been using a few Bitnami ones today for an upcoming blog post with pretty good success.

Consider giving that a whirl?


So just pick up a chart from the bitnami repository (like nginx) fork/clone and use that instead of mine - any changes would be needed to that chart to use with harness?

@Ravi - but as such you did not notice any specific issue with the chart.
And the error “can not find chart.yaml” - sort of does not make any sense.

To close the loop on this chart. helm lint does not return any error and I can install it successfully without harness (helm install) on this same GKE cluster.



I did not go through your GitHub repo. Suggesting you validate the format. Helm is like APT /
RPM so structure is important. Where did you get your Chart? How did you create the Chart?

Check out Bitnami’s guide:

Helm Charts:

I’ll be publishing a zero to hero blog next week. Might be helpful.

Any specific goals you have or just poking around?
Harness is a great platform to learn on!


Generally poking around, need to get done a POC.
You can try clone my repo and see if it works. As I said, I can install this chart successfully on my GKE cluster without harness. So I somehow am not getting the harness stuff right.

I created a basic helm chart tried to deploy, get same error: no Chart.yaml exists in directory

Rendering chart using Helm

ERROR 2019-11-29 18:58:47 Error: no Chart.yaml exists in directory "/opt/harness-delegate/repository/k8s/c6f2b2e4-f5ba-3e77-a5de-31755b57d1d8/manifest-files"

ERROR 2019-11-29 18:58:47 Failed to render helm chart. Error


Not too sure about that. I’ll ask around for you.


Yeah, I am using a default chart and following the prescribed steps to do a simple hello world.

Additionally I could not get this going at all on AWS/EKS- I could install the delegate (after lot of effort)- it likely was memory issue. I could add the AWS cloud provider - test 'Successful". But it would not show up in the drop down of cloud providers. There were no such issues with GCP/GKE.

On the previous thread, would help to understand 1. How did you create your EKS Cluster? 2. How did you modify your EKS Cluster? 3. Did you ever recreate your EKS Cluster?

From personal experience I’ve had some weird items creation / maintenance wise on EKS. I had to resort to EKSCTL’s Cloud Formation stack.

Similar I had the best experience on GKE,
OpenShift, and Mesosphere DC/OS running the latest K8’s version.

Assuming you right sized your GKE the first to after the learnings on EKS :slight_smile:

AWS/EKS - I used the console to create the cluster. The issue with EKS - it defaults to 4GB which does not work with harness (unlike GKE which defaults to 15GB). To upgrade you have delete the node (not the cluster itself) and re-create node with 16B (even 8GB does not work). But after all that I had a good working K8s cluster- could install the delegate and add the aws cloud provider, but ultimately still fails with harness.


I created a blog post that walks through an EC2/EKS Helm 2.16.x stack.

Not sure if that would satisfy what you are doing for your PoC.