DRONE_YAML not recognized


I am on 0.8 and trying to use an alternate yaml file for my server, I have set DRONE_YAML like so:


However, drone is still picking up .drone.yml


The global DRONE_YAML environment variable was removed and replaced with the ability to customize the filename per-repository:

drone repo update --config=.myfile.yml octocat/hello-world

Thanks for the reply!

For some reason I am getting a 404:

$ drone -version
drone version 0.8.5
$ drone repo update --config=.myfile.yml myorg/myrepo
client error 404:

But I am able to change the trusted setting:

$ drone repo update --trusted myorg/myrepo
Successfully updated repository myorg/myrepo

I don’t see anything in the server logs.

I’m not sure what I had wrong before, but it is working now.

Thanks for the help!

If we are planning to have 100 repositories using .drone.star instead of .drone.yml, a global DRONE_YAML would be helpful. right? any ideas about how to handle this change globally?

If we are planning to have 100 repositories…

The answer, based on your previous comment about “drone repo update”.

export DRONE_SERVER=set
export DRONE_TOKEN=set
cat list_of_repos | xargs -I % drone repo enable %
cat list_of_repos | xargs -I % drone repo update --config .drone.star %