Drone web interface no logs after build started

Yesterday I installed drone (latest version) to my Ubuntu server which uses docker and gitea. I can reach the drone web interface and can see my repositories. Drone is behind reverse proxy (nginx) - here is the nginx configuration.

upstream drone {

map $http_upgrade $connection_upgrade {
    default upgrade;
    ''      close;

server {
    listen 80;
    listen [::]:80;

    server_name drone.myserver.net;

    root /var/www/drone.myserver.net/html;
    index index.html index.htm;

    client_max_body_size 20M;

    location / {
        proxy_pass http://drone;

        include proxy_params;
        proxy_set_header Upgrade $http_upgrade;
        proxy_set_header Connection $connection_upgrade;

        proxy_redirect off;
        proxy_http_version 1.1;
        proxy_buffering off;
        chunked_transfer_encoding off;
        proxy_read_timeout 86400;

The runner is on Windows - exec. I can access it at http://localhost:3000/logs. The log displays starting the server, successfully pinged the remote server, polling the remote server.

In the /etc/drone/server.env I enabled jsonnet too:

I created a testing repository DockerTest with following .drone.jsonnet file:

    "kind": "pipeline",
    "type": "docker",
    "name": "default",

    "steps": [
            "name": "build",
            "image": "golang",
            "commands": [
                "echo hello world",

Using the drone web interface I found my repository, activated it and in the Settings tab set Configuration = .drone.jsonnet. The in Builds tab I clicked New Build which told me Build successfully created. I clicked the build (under Executions). I can see that it is (probably) running, however the Pipeline stages displays only “default” - can’t click it (expand it) and the Console Logs just displays Loading…

Any idea what can be wrong?
Thanks in advance :slight_smile:

Apparently the issue is with Window exec runner and maybe my jsonnet file. If I disable my exec runner and install a docker runner on Ubuntu it works. :open_mouth: