Drone stopped authenticating


I had to change my server because the old one died. I switched everything onto the new server and started with docker-compose, everything is reachable and works fine except drone. Everytime I tried to authenticate I run into following error:
Login Failed. <small>Post "https://gitea.xxx.yyy/login/oauth/access_token": dial tcp connect: no route to host</small>

When I try to ping my gitea instance from the drone container, it works without any issues.

are you running the latest version of Drone and Gitea? Gitea switched from basic authentication to oauth2 authentication. The error would indicate you may be running an old version of Gitea that lacks oauth2, or you did not configure a Gitea oauth2 application. You may also want to check with the Gitea community support to see if there was a regression.

I am running 1.12.1. I think that’s the latest.
I also opened a request at the gitea community.

The no route to host indicates a networking issue that prevents requests from reaching the target. Are you sure the address and port are reachable from inside the Drone container? Have you tried to curl or wget instead of ping? Are there firewall rules that could be blocking traffic at the https port, for example?

thanks, yes it must have been some firewall stuff. I switched from opensuse to ubuntu and now it is working fine again.