Drone setup behind corporate proxy agents not working

Hi ,

I have 3 node setup for drone ci/cd . Breakup of cluster is like below

  1. master node
  2. worker node
  3. worker node

docker configuration on all nodes is as follow

Containers: 4
Running: 3
Paused: 0
Stopped: 1
Images: 8
Server Version: 18.03.0-ce
Storage Driver: devicemapper
Pool Name: docker-253:0-8638318-pool
Pool Blocksize: 65.54kB
Base Device Size: 10.74GB
Backing Filesystem: xfs
Udev Sync Supported: true
Data file: /dev/docker/docker-data
Metadata file: /dev/docker/docker-metadata
Data Space Used: 1.27GB
Data Space Total: 96.64GB
Data Space Available: 95.37GB
Metadata Space Used: 2.531MB
Metadata Space Total: 9.664GB
Metadata Space Available: 9.661GB
Thin Pool Minimum Free Space: 9.664GB
Deferred Removal Enabled: true
Deferred Deletion Enabled: true
Deferred Deleted Device Count: 0
Library Version: 1.02.140-RHEL7 (2017-05-03)
Logging Driver: json-file
Cgroup Driver: cgroupfs
Volume: local
Network: bridge host macvlan null overlay
Log: awslogs fluentd gcplogs gelf journald json-file logentries splunk syslog
Swarm: active
NodeID: 2a0251y2jr6tkj0gm38czyhxl
Is Manager: true
ClusterID: t18w08zzcwj8dks21c8ghqt8r
Managers: 1
Nodes: 3
Task History Retention Limit: 5
Snapshot Interval: 10000
Number of Old Snapshots to Retain: 0
Heartbeat Tick: 1
Election Tick: 3
Heartbeat Period: 5 seconds
CA Configuration:
Expiry Duration: 3 months
Force Rotate: 0
Autolock Managers: false
Root Rotation In Progress: false
Node Address: xxx.xx.xx.19
Manager Addresses:
Runtimes: runc
Default Runtime: runc
Init Binary: docker-init
containerd version: cfd04396dc68220d1cecbe686a6cc3aa5ce3667c
runc version: 4fc53a81fb7c994640722ac585fa9ca548971871
init version: 949e6fa
Security Options:
Profile: default
Kernel Version: 3.10.0-229.el7.x86_64
Operating System: CentOS Linux 7 (Core)
OSType: linux
Architecture: x86_64
CPUs: 2
Total Memory: 1.78GiB
Name: node1.docker.com
Docker Root Dir: /var/lib/docker
Debug Mode (client): false
Debug Mode (server): true
File Descriptors: 72
Goroutines: 210
System Time: 2018-04-10T16:44:22.502466121+05:30
EventsListeners: 3
HTTP Proxy: http://xxx.xx.xxx.xxx:3128/
HTTPS Proxy: http://xxx.xx.xxx.xxx:3128/
No Proxy: localhost,,registry.docker.com:5000
Registry: https://index.docker.io/v1/
Experimental: false
Insecure Registries:
Live Restore Enabled: false

We have a private registry hosted in our infrastructure .

drone-agent are connected to drone-server and I have configured Bitbucket cloud to be used with drone server. Webhooks are working ( with timeouts ).

I have a maven based projects in my repository to which want to create a build and deploy it to docker container.

I have set http_proxy/HTTP_PROXY with docker daemon to all nodes within cluster. But while build is going on maven is not able to pull artifact from central repository. Even I tried to pass http_proxy within maven command but still no success .

Any help is greatly appreciated .

Have you verified connectivity to your maven server from inside a Docker container? This sounds like a Docker or host machine network issue, as opposed to a Drone issue. I would try ping your maven server using the following commands:

docker network create foo
docker run --network=foo -t -i alpine ping -c 1 you.maven.server.com

Hi bradrydzewski,

Thanks for impromptu reply, i was able to solve that issue by applying -Dhttps.proxyHost=my.host.com.
Problem was my maven is requesting a artifact download from secured repo, but I haven’t configured it .

Another problem I am facing that after build process kicks in my maven is able to get artifact from maven properly, but even now build fails without showing any error. Is there any way to check why build fails.

I have set mysql as a db server for drone, but there i was not able to see any agent entry, even though agents are alive and connected to server.

Any insight is grealty appreciated