Drone/pr build check not disabled when disable pull requests checked

I disabled pull requests in the repo settings in Drone, but the check for continuous-integration/drone/pr will not go away. It keeps popping up for new PR and of course doesn’t do anything, so all of our PRs are stalled and won’t allow merge without admin action.

Other repos where I’ve tried disabling pull requests doesn’t seem to do this. I’ve also tried unchecking pull requests in the webhook settings, but that had no effect. I also tried deactivating and reactivating the repo in Drone and that had no effect.

It sounds like you have protected branches / required checks enabled for the repository. If you enable protected branches and you require a status check, GitHub automatically adds the status check when the pull request is created with the message “Waiting for status to be reported”.

This means GitHub is automatically adding the status, not Drone. If you would like to prevent the status from being added you need to change your GitHub settings. There are no additional actions that need to be taken in Drone.

I thought that might be the case, but so far have not found the relevant setting. I’ll keep digging a bit more, though.

A status created by Drone will have an initial message that reads “build is pending” [1]. The only way for a status to be created with “Waiting for status to be reported” is when the status is automatically added by GitHub.

[1] https://github.com/drone/drone/blob/master/service/status/util.go#L40:65

Ok I did find the protected branch check. I had similar settings on my other repos, so not sure why this one was problematic, but the issue is definitely solved by removing that check on the protected branch settings. Thanks!

here is a similar thread in the github support channel, which describes the setting that needs to be changed and includes a screenshot https://github.community/t/expected-waiting-for-status-to-be-reported/18001/2