Drone not Triggering Runner in Gitea Repo

Hi All,

Have been using Drone and Gitea for a while with one ssh runner, things seemed to work fine, builds start as expected when a commit takes place.

Then tried to add another ssh runner, this time the runner is not triggered, basically the only way to get the build is by clicking on the big blue New Build button.

The two repos are basically identical, albeit the runners are running on different hosts. Noticed also that the new repo does not have a webhook created in Gitea, whereas the first repo corresponding to the working runner does.

Also the Drone console Repositories > Branches tab shows the master branch for the working runner but not for the second one.

Checked logs of both server and runner, the server log has this error (not sure if relevant):

{"error":"stream: not found","level":"warning","msg":"manager: cannot teardown log stream","step.id":42,"step.name":"test","step.status":"skipped","time":"2023-04-17T14:58:10Z"}

What could be wrong here?


Just tried another fresh repo with exactly the same results, namely:

Builds are not triggered automatically.
No Webhook created on Gitea’s side.

Other than that the manual builds behave normally and there are no errors in any logs.

This could be a bug and is definitely a show stopper from our perspective as we’ve spend a considerable amount of time trying to set up this installation.

Can someone from the Drone team give us an indication as to what could be happening?