Drone CLI does not accept custom tokens during user creation

$ openssl rand -hex 16
$ drone user add myuser --admin --machine --token=312b9edfc5cfc4aacf7e56a9835f7d80
Successfully added user myuser
Generated account token lNPig1Ktu1fvsNLL2JLLH8PjYGPP5a72

$ drone --version
drone version 1.2.2

The token passed to the --token flag by the admin gets never applied, instead Drone CLI is generation its own token…

there was previously a bug creating tokens, but this was fixed a few months back:

But as you can see it’s still not working in the latest release. Or do I miss something?

the version printed above is the CLI version. This fix was made to the server, so you need to make sure you are running the latest server version.

Still not working:

6dc0a5fcf716        drone/drone:1.9.1               "/bin/drone-server"      17 hours ago        Up 17 hours

Using the custom token that I have passed (and ignoring the token that the cli displayed after user creation):

export DRONE_TOKEN=312b9edfc5cfc4aacf7e56a9835f7d80
$ drone info
client error 401: {"message":"Unauthorized"}