Drone CICD Not auto Build

i am using drone and gitea with docker everything works fine, however i noticed the drone is not build automatically i have to do this manually, what i want is after i push my code to gitea then drone can run build automatically

i do know cronjob feature but that’s not what i need because sometimes i push code i need it to run always without scheduling.

All software I use latest version.

Hey ! welcome.

I would recommend reading through Nothing happens when I push code, webhooks not working, no builds, or builds stuck in pending first. If you dont resolve your issue. can you post some more information about your setup. As there is nothing to go on here

i read it but how can i find the webhook secret? I have set environment variable DRONE_WEBHOOK_SECRET but they are not working.

i solved this problem by converting http POST to http GET. problem solved,

I am unfamiliar with gitea, so i can only speak in generalities.
Make sure that you have setup the server Gitea | Drone
Check inside of gitea for the webhook settings for your repo eg webhook config and use test delivery
It is going to be one of these things.