Drone Ci, Private Registry, Kubernetes


I have a connection problem to a private registry with Drone CI. My existing infrastructure contains Kubernetes, Private Registry, Drone CI.

When I use public dns of the registry, everything works fine, but I would like to close external connection to the registry and make it available only through the private kubernetes network. In my case I have internal dns docker-registry.docker-registry and I can access to the registry from another container which is available in the cluster, but I get error “Error authenticating: exit status 1” when I do it from my Drone CI during the build process. The issue is definitely not in authentification because I could put any dns name and still will get “Error authenticating: exit status 1”.

My drone version is 0.8.5
Installed from helm chart, drone agent contains dind.

My assumption that there is no access to internal network from environment where build happens.

can you provide some more details? Are these errors coming from the Docker plugin (http://plugins.drone.io/drone-plugins/drone-docker/)? Have you tried setting the custom_dns property to point to your internal DNS server?

Sure. Error comes from docker plugin. I tried custom DNS option by passing which is ip of kube DNS service but it didn’t help.

do you need to set the --dns option in the dind container you are running?

also I wonder if anything in this thread is relevant? Controlling the CIDR for bridge networks created by Drone?