Drone CI pipeline first step clone failed: Connection refused

I just installed drone in my k8s cluster as well as kube runner

Our git server is bitbucket, so I configure a lot of variables and install it by helm

I skip certificate verify because the cert of bitbucket is self-signed

It seems everything is ok at first, but when I try running the ci, the clone step failed:

I am really confused about it and have no idea how to solve this problem

Our bitbucket can also be visited by external traffic, so this should not a firewall probelm

Or is there any way I clone the repo by ssh instead of https?

Is your bitbucket instance configured to use private mode? If so, you probably need to configure Drone to always authenticate when cloning using the DRONE_GIT_ALWAYS_AUTH server setting.

I set it as TRUE but unlucky

I modify the drone/clone and I find something:

I both ping and curl google in drone/clone container

I found that ping work but curl fail which told me “connection refused”

So I believe there is something wrong of network in kube-runner container

I still try to figure it out

Btw, I can run all the commands successfully out of the container, so is it possible to let the kube runner and its pipeline running under the ‘host’ network

I finally find the problem, we have istio in our environment

when kube-runner start, istio injects a side-car container in the pipeline container which messes up the network

I turn off the inject option and then it works well