Drone 2.0 - Graph view inside pipeline always shown as sequential

I have just updated to the latest tag from Dockerhub and I have to say great work towards improving the UI!

The issue:

We use a Drone config consisting of separate pipelines but a graph configuration inside the pipeline.

We have many steps of the pipeline running in parallel but despite that they are being displayed sequentially in the graph view. In the screenshot for example frontend_test and frontend_build are running in parallel although not displayed as such.


This is a known limitation. We do not currently store any data in the drone database to render the pipeline steps as a graph (we do store graph data for stages, but not steps). We have an open pull request that adds the necessary fields to the database to store the step graph (see https://github.com/drone/drone/pull/3072) which would in turn make it available to the UI for correct rendering.

We also had to make changes to the runners to send this data to the server to persist. This change is already available in the latest version of the Docker runner.


Thanks, I’ll keep an eye on that PR!

This would be great! The graph isn’t very useful if its just a horizontal view of the normal log view ordering. I’m anticipating this feature as well :slight_smile:

We currently show the graph for stages (top half) but not for steps (bottom half) due to Drone not storing the necessary data in the database to render. We are planning to enhance the step visualization to support graph rendering in the 2.1.0 release.


Hi brad,

I saw that the PR is merged (which stores graph data for steps). But it looks like the steps are still displayed sequential.
Is there any update on when this will be fixed?


Hi Simon,

Are you seeing this bug in locally deployed drone or cloud.drone.io?

Hi @d1wilko , I’m seeing this in a locally deployed drone.
When looking at the execution of the steps, they do run parralel like I want, just the graph view is still sequential.

Running drone 2.1.0

This was fixed in Drone 2.0.2 (see below screenshot)

You need to also make sure you are running the latest version of the runner, and the runner must be using runner-go version 1.7.0 or higher. You can check the runner-go version of your runner by inspecting the go.mod file in the repository, for example, here is go.mod for the docker runner.

1 Like

Thanks! I’ll have a look what version drone autoscaler deploys.

I should also point out that older builds will continue to display sequentially because the database will not have sufficient data to render graph structures. Only newer builds, executed by a newer runner, will have sufficient data to render the graph.

Setting DRONE_AGENT_IMAGE to drone/drone-runner-docker:latest instead of the tag 1 fixed it.
Thanks for the quick response

When will this be released with a semver autotag instead of latest?
We really want to use it, but not risk using latest, and have something break in the future.

1 Like

I just noticed there is now a 1.7.0 published that should contain the fix.

1 Like

I would like to have the dual (stages/steps) graph using the drone-runner-exec which uses runner-go version 1.3.1. To do so, I bumped up the runner-go and drone-go versions to latest (v1.12.0 and v1.7.1 respectively). However, as expected, Drone UI still doesn’t display parallel steps as graph but parallel stages are displayed as graphs. What needs to be implemented in the runner to actually fix the bottom steps view graph rendering?