Drone 1.0.0-rc5 on kubernetes - shebang header not working


we’re testing drone 1.0.0-rc5 on kubernetes with the goal of switching from drone 0.8.x.
We are running kubernetes at google, GKE 1.10.7-gke.1 at the moment.

We’re seeing that the shebang header does not appear to work correctly:
/bin/sh: 1: tsc: Permission denied

For example in the nodejs world shebang headers such as #!/usr/bin/env/ node are not uncommon, also calling them pre/post build is not uncommon.

These steps worked fine in the old drone environment.

Calling these binaries with the respecive interpreter works fine. However certain build systems assume that the shebang header works.

I cannot really explain this since it’s docker in docker.
Do you guys have any ideas/suggestions?

Thank you,

With kind regards,


Hey! I’m running into the same problems, but just executing any scripts at all which are part of either my source code, or anything which is written to the workspace directory.

Check out Permission denied when trying to execute script for more details about what I’ve tried.

It looks like there is another thread discussing this issue. Lets combine into a single thread at Permission denied when trying to execute script