Docker runner connection refused

I’m getting the following error when trying to use a docker runner:

+ git fetch origin +refs/heads/master:
fatal: unable to access 'http://localhost:3030/Enhex/test.git/': Failed to connect to localhost port 3030: Connection refused

duplicate of [Solved]Unable to access repository but I can clone inside the docker drone.

that’s kinda weird because I’m running everything on host network.
my ROOT_URL in the app.ini file is set to, so I’m not sure where the localhost comes from.
DRONE_RUNNER_NETWORKS didn’t seem to help either.

Also is there an option to run the docker runner without a docker container?
So far it only causes trouble and I don’t see any need for it to be in a container.

NOTE: without host network drone itself gets connection refused:
Login Failed. Post "": dial tcp connect: connection refused

trying to use container IPs instead of host network results:

Authorization failed
Unregistered Redirect URI

The authorization failed because we detected an invalid request. Please contact the maintainer of the app you've tried to authorize.