Digitalocean runner deletes instance after successful connection

I’m using the Drone digital ocean runner inside a docker container.

The runner is successfully polling the drone server and receiving jobs. It even goes as far as provisioning the machine.

However, after it successfully connects via SSH (or at least I think it does), it immediately kills the instance. Below are the logs. As you can see, after “completing” the configuration, 1ms later it kills the instance.

time="2021-08-25T13:53:10Z" level=debug msg="server configuration complete" hostname=drone-temp-v7yd4ONuL3vPJ1np id=261720165 ip=
time="2021-08-25T13:53:11Z" level=debug msg="terminating server" hostname=drone-temp-v7yd4ONuL3vPJ1np id=261720165 ip=
time="2021-08-25T13:53:11Z" level=debug msg="updated stage to complete" build.number=1551 repo.namespace=chainflip-io stage.number=1 thread=2
time="2021-08-25T13:53:11Z" level=debug msg="request stage from remote server" thread=2
time="2021-08-25T13:53:11Z" level=trace msg="http: context canceled"
time="2021-08-25T13:53:11Z" level=debug msg="done listening for cancellations" build.number=1551 repo.namespace=chainflip-io stage.number=1 thread=2

I see that the docker-runner repo has not been touched in a year, so I guess it might be sunset?

I actually worked it out in the end. It was because I had depends_on set in several places referring to steps that did not exist.

However, I ran the runner locally, it failed to handle the error properly so the job things it passed.