Ctrl+c received, terminating process

I try to build a sample project with the following .drone.yml:

    image: ubuntu
      - apt-get update
      - apt-get install --yes curl
      - curl -v google.de

When I try to build a sample project the build is not starting and I get the following error message in the logs:

drone-agent_1   | {"time":"2018-05-12T13:27:36Z","level":"debug","message":"request next execution"}
drone-agent_1   | ctrl+c received, terminating process
drone-agent_1   | 2018/05/12 13:29:07 grpc error: done(): code: Canceled: rpc error: code = Canceled desc = context canceled
drone-agent_1   | {"time":"2018-05-12T13:29:07Z","level":"error","error":"rpc error: code = Canceled desc = context canceled","message":"pipeline done with error"}
drone-agent_1   | {"time":"2018-05-12T13:41:40Z","level":"debug","message":"request next execution"}

Does anybody know what could be the problem, or how I can get a more verbose error log?

based on the logs it looks like your container received a SIGKILL from somewhere (OS, etc) and shutdown, and is therefore not processing builds.

We are having the same error but we don’t know exactly how we can debug it… the pipeline commands seem that they work when it is ran inside the docker (in our case, inside a python image), but it is tried to use via drone, it doesn’t work…
I did some changes, In the test steps, we only added an echo command, but it keeps not working… It seems some connection issue or similar…

ctrl+c received, terminating process

This error message above (which is what this thread refers to) indicates that something external to Drone on your host OS is killing the agent (or maybe killing Docker which in turn kills the agent). This is not something you can debug within Drone; this is a third party that is killing the running agent. You need to look at your host OS and figure out what is killing the agent and why.