Creating a new build with a branch name with a slash causes an error?

You can see in the diagram that when I select a branch name with a slash to build it, a 404 error occurs.

my drone version : drone/drone:2.4
my drone runner version : drone/drone-runner-docker:1

Thank you for reaching out to Harness Support. We tried to reproduce this issue on our end as well and did not run into the same behaviour. We created a new branch with the name “zee/drone” and had a build succeed.

Here are the steps we performed :-

  • We had a master branch which contained our drone.yaml

  • We made changes to the yaml file here and then committed it as part of a new branch “zee/drone”

  • We could then confirm that the commit for this new branch works as expected without the 404 due to the slash in the branch name

Could you please share with us the steps you performed so that we can try reproducing this on our end as well ?

Harness Support

i got this problem too. i have tried many times. trigger by REST API and pass branch params must encode twice so it can trigger success, but the clone step went error. such as i got a branch name “feature/test” i encode twice got ‘feature%252Ftest’ this will trigger build successfully , but the clone step will got error because the branch name isn’t right which liket this:

Initialized empty Git repository in /drone/src/.git/ 0s

2+ git fetch origin ‘+refs/heads/feature%2Ftest:’ 0s

3fatal: couldn’t find remote ref refs/heads/feature%2Ftest